const regex = /(?:http:\/\/)?www.liveleak.com\/view\?i=(\w{14})/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:http:\\\/\\\/)?www.liveleak.com\\\/view\\?i=(\\w{14})', 'gi')
const str = `www.liveleak.com/view?i=3f5_1213987712
http://www.liveleak.com/view?i=3f5_1213987712`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}