$re = '/(?:http:\/\/)?www.liveleak.com\/view\?i=(\w{14})/i';
$str = 'www.liveleak.com/view?i=3f5_1213987712
http://www.liveleak.com/view?i=3f5_1213987712';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);