use strict;
my $str = 'www.liveleak.com/view?i=3f5_1213987712
http://www.liveleak.com/view?i=3f5_1213987712';
my $regex = qr/(?:http:\/\/)?www.liveleak.com\/view\?i=(\w{14})/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}