# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(Loves.*")$/$1 Very Much/gim;t' <<< "DOLLY Loves DOLLS\" Like Elephant\"
DOLLY;
DOLLY Loves DOLLS Like Dog\"
DOLLY Loves DOLLS Like Cat\" But Bats Not
DOLLY \"Loves\" Her Lover Matt
Mr. O' Neil\" King Hates Dolls
DOLLY Loves DOLLS Like Bat\"
DOLLY;"