const regex = /(Loves.*")$/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(Loves.*")$', 'gim')
const str = `DOLLY Loves DOLLS" Like Elephant"
DOLLY;
DOLLY Loves DOLLS Like Dog"
DOLLY Loves DOLLS Like Cat" But Bats Not
DOLLY "Loves" Her Lover Matt
Mr. O' Neil" King Hates Dolls
DOLLY Loves DOLLS Like Bat"
DOLLY;`;
const subst = `$1 Very Much`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);