// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?im)(Loves.*")$"#).unwrap();
let string = "DOLLY Loves DOLLS\" Like Elephant\"
DOLLY;
DOLLY Loves DOLLS Like Dog\"
DOLLY Loves DOLLS Like Cat\" But Bats Not
DOLLY \"Loves\" Her Lover Matt
Mr. O' Neil\" King Hates Dolls
DOLLY Loves DOLLS Like Bat\"
DOLLY;";
let substitution = "$1 Very Much";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}