$re = '/(Loves.*")$/im';
$str = 'DOLLY Loves DOLLS" Like Elephant"
DOLLY;
DOLLY Loves DOLLS Like Dog"
DOLLY Loves DOLLS Like Cat" But Bats Not
DOLLY "Loves" Her Lover Matt
Mr. O\' Neil" King Hates Dolls
DOLLY Loves DOLLS Like Bat"
DOLLY;';
$subst = "$1 Very Much";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;