#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?im)(Loves.*")$"
Local $sString = "DOLLY Loves DOLLS" Like Elephant"" & @CRLF & _
"DOLLY;" & @CRLF & _
"DOLLY Loves DOLLS Like Dog"" & @CRLF & _
"DOLLY Loves DOLLS Like Cat" But Bats Not" & @CRLF & _
"DOLLY "Loves" Her Lover Matt" & @CRLF & _
"Mr. O' Neil" King Hates Dolls" & @CRLF & _
"DOLLY Loves DOLLS Like Bat"" & @CRLF & _
"DOLLY;"
Local $sSubst = "$1 Very Much"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)