import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(Loves.*\")$";
final String string = "DOLLY Loves DOLLS\" Like Elephant\"\n"
+ "DOLLY;\n"
+ "DOLLY Loves DOLLS Like Dog\"\n"
+ "DOLLY Loves DOLLS Like Cat\" But Bats Not\n"
+ "DOLLY \"Loves\" Her Lover Matt\n"
+ "Mr. O' Neil\" King Hates Dolls\n"
+ "DOLLY Loves DOLLS Like Bat\"\n"
+ "DOLLY;";
final String subst = "$1 Very Much";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}