# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(Loves.*\")$"
test_str = ("DOLLY Loves DOLLS\" Like Elephant\"\n"
"DOLLY;\n"
"DOLLY Loves DOLLS Like Dog\"\n"
"DOLLY Loves DOLLS Like Cat\" But Bats Not\n"
"DOLLY \"Loves\" Her Lover Matt\n"
"Mr. O' Neil\" King Hates Dolls\n"
"DOLLY Loves DOLLS Like Bat\"\n"
"DOLLY;")
subst = "$1 Very Much"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE | re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.