import Foundation
let pattern = #"(Loves.*")$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
DOLLY Loves DOLLS" Like Elephant"
DOLLY;
DOLLY Loves DOLLS Like Dog"
DOLLY Loves DOLLS Like Cat" But Bats Not
DOLLY "Loves" Her Lover Matt
Mr. O' Neil" King Hates Dolls
DOLLY Loves DOLLS Like Bat"
DOLLY;
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1 Very Much"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)