# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\pL),(?!\s)/, /g;t' <<< "Hello,there = Hello, there
Hello, there = Hello, there
He said,\"Hi.\" = He said, \"Hi.\"
"