import Foundation
let pattern = #"(?<=\pL),(?!\s)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Hello,there = Hello, there
Hello, there = Hello, there
He said,"Hi." = He said, "Hi."
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #", "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)