$re = '/(?<=\pL),(?!\s)/';
$str = 'Hello,there = Hello, there
Hello, there = Hello, there
He said,"Hi." = He said, "Hi."
';
$subst = ", ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;