use strict;
my $str = 'Hello,there = Hello, there
Hello, there = Hello, there
He said,"Hi." = He said, "Hi."
';
my $regex = qr/(?<=\pL),(?!\s)/p;
my $subst = ', ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";