using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\pL),(?!\s)";
string substitution = @", ";
string input = @"Hello,there = Hello, there
Hello, there = Hello, there
He said,""Hi."" = He said, ""Hi.""
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}