re = /(?<=\pL),(?!\s)/
str = 'Hello,there = Hello, there
Hello, there = Hello, there
He said,"Hi." = He said, "Hi."
'
subst = ', '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result