const regex = /(?<=\pL),(?!\s)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\pL),(?!\\s)', 'g')
const str = `Hello,there = Hello, there
Hello, there = Hello, there
He said,"Hi." = He said, "Hi."
`;
const subst = `, `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);