# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([^;]*;){2}([^;]*)$/$1Hello$3/;t' <<< "asdf :: qwer :: fghd"