$re = '/^([^;]*;){2}([^;]*)$/';
$str = 'asdf :: qwer :: fghd';
$subst = "$1Hello$3";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;