re = /^([^;]*;){2}([^;]*)$/
str = 'asdf :: qwer :: fghd'
subst = '$1Hello$3'
result = str.sub(re, subst)
# Print the result of the substitution
puts result