using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^;]*;){2}([^;]*)$";
string substitution = @"$1Hello$3";
string input = @"asdf :: qwer :: fghd";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}