// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^([^;]*;){2}([^;]*)$").unwrap();
let string = "asdf :: qwer :: fghd";
let substitution = "$1Hello$3";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}