const regex = /^([^;]*;){2}([^;]*)$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([^;]*;){2}([^;]*)$', '')
const str = `asdf :: qwer :: fghd`;
const subst = `$1Hello$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);