#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^([^;]*;){2}([^;]*)$"
Local $sString = "asdf :: qwer :: fghd"
Local $sSubst = "$1Hello$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)