use strict;
my $str = 'asdf :: qwer :: fghd';
my $regex = qr/^([^;]*;){2}([^;]*)$/p;
my $subst = '$1Hello$3';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";