package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*?): (.*)`)
var str = `Matthäuspassion, SWV 479: Introitus:Test
Matthäuspassion, SWV 479:Introitus:Test
letztlich
Matthäuspassion, SWV 479: Introitus - Test
Erster Text, zweiter Text : Dritter Text
Vierter Text, fünfter Text : Sechster Text
Siebter Text, achter Text : Neunter Text`
var substitution = "$1 xxx $2"
fmt.Println(re.ReplaceAllString(str, substitution))
}