import re
regex = re.compile(r"(.*?): (.*)", flags=re.MULTILINE)
test_str = ("Matthäuspassion, SWV 479: Introitus:Test\n"
"Matthäuspassion, SWV 479:Introitus:Test\n"
"letztlich\n"
"Matthäuspassion, SWV 479: Introitus - Test\n\n"
"Erster Text, zweiter Text : Dritter Text\n"
"Vierter Text, fünfter Text : Sechster Text\n"
"Siebter Text, achter Text : Neunter Text")
subst = "$1 xxx $2"
result = regex.sub(subst, test_str)
if result:
print(result)