re = /(.*?): (.*)/m
str = 'Matthäuspassion, SWV 479: Introitus:Test
Matthäuspassion, SWV 479:Introitus:Test
letztlich
Matthäuspassion, SWV 479: Introitus - Test
Erster Text, zweiter Text : Dritter Text
Vierter Text, fünfter Text : Sechster Text
Siebter Text, achter Text : Neunter Text'
subst = '$1 xxx $2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result