const regex = /(.*?): (.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*?): (.*)', 'gm')
const str = `Matthäuspassion, SWV 479: Introitus:Test
Matthäuspassion, SWV 479:Introitus:Test
letztlich
Matthäuspassion, SWV 479: Introitus - Test
Erster Text, zweiter Text : Dritter Text
Vierter Text, fünfter Text : Sechster Text
Siebter Text, achter Text : Neunter Text`;
const subst = `$1 xxx $2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);