import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*?): (.*)";
final String string = "Matthäuspassion, SWV 479: Introitus:Test\n"
+ "Matthäuspassion, SWV 479:Introitus:Test\n"
+ "letztlich\n"
+ "Matthäuspassion, SWV 479: Introitus - Test\n\n"
+ "Erster Text, zweiter Text : Dritter Text\n"
+ "Vierter Text, fünfter Text : Sechster Text\n"
+ "Siebter Text, achter Text : Neunter Text";
final String subst = "$1 xxx $2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}