#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(<number>[^\S\n]*){2,}"
Local $sString = "<number><number>" & @CRLF & _
"<number> <number>" & @CRLF & _
"not <number> test <number>" & @CRLF & _
" <number> <number> test" & @CRLF & _
"<number> <number> <number><number><number> <number> "
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)