re = /(<number>[^\S\n]*){2,}/m
str = '<number><number>
<number> <number>
not <number> test <number>
<number> <number> test
<number> <number> <number><number><number> <number> '
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result