// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(<number>[^\S\n]*){2,}").unwrap();
let string = "<number><number>
<number> <number>
not <number> test <number>
<number> <number> test
<number> <number> <number><number><number> <number> ";
let substitution = "\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}