package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(<number>[^\S\n]*){2,}`)
var str = `<number><number>
<number> <number>
not <number> test <number>
<number> <number> test
<number> <number> <number><number><number> <number> `
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}