use strict;
my $str = '<number><number>
<number> <number>
not <number> test <number>
<number> <number> test
<number> <number> <number><number><number> <number> ';
my $regex = qr/(<number>[^\S\n]*){2,}/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";