const regex = new RegExp('(<number>[^\\S\\n]*){2,}', 'gm')
const str = `<number><number>
<number> <number>
not <number> test <number>
<number> <number> test
<number> <number> <number><number><number> <number> `;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);