using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""[^""]*(for|while)\s[^""]*""";
string substitution = @"";
string input = @"PERFORM xxkkcsort.f_write_log(""INFO"", ""xxkkcsort.f_load_tables__outof_order_system"", ""> Table for loading: ""||cc.source_table_name , false, null::text, 0);";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}