import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"[^\"]*(for|while)\\s[^\"]*\"";
final String string = "PERFORM xxkkcsort.f_write_log(\"INFO\", \"xxkkcsort.f_load_tables__outof_order_system\", \"> Table for loading: \"||cc.source_table_name , false, null::text, 0);";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}