re = /"[^"]*(for|while)\s[^"]*"/m
str = 'PERFORM xxkkcsort.f_write_log("INFO", "xxkkcsort.f_load_tables__outof_order_system", "> Table for loading: "||cc.source_table_name , false, null::text, 0);'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result