// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)"[^"]*(for|while)\s[^"]*""#).unwrap();
let string = "PERFORM xxkkcsort.f_write_log(\"INFO\", \"xxkkcsort.f_load_tables__outof_order_system\", \"> Table for loading: \"||cc.source_table_name , false, null::text, 0);";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}