const regex = /"[^"]*(for|while)\s[^"]*"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"[^"]*(for|while)\\s[^"]*"', 'gm')
const str = `PERFORM xxkkcsort.f_write_log("INFO", "xxkkcsort.f_load_tables__outof_order_system", "> Table for loading: "||cc.source_table_name , false, null::text, 0);`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);