#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d{3,5}([- ]?\d{4})?$"
Local $sString = "27364" & @CRLF & _
"2839" & @CRLF & _
"37567-2839" & @CRLF & _
"28448 3950" & @CRLF & _
"3847933" & @CRLF & _
"28448 3953" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"3" & @CRLF & _
"3858049494" & @CRLF & _
"38494 4" & @CRLF & _
"49500-" & @CRLF & _
"49500-35" & @CRLF & _
"49500-35-34" & @CRLF & _
"-32893-3429" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")