// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d{3,5}([- ]?\d{4})?$").unwrap();
let string = "27364
2839
37567-2839
28448 3950
3847933
28448 3953
3
3858049494
38494 4
49500-
49500-35
49500-35-34
-32893-3429
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}