const regex = /^\d{3,5}([- ]?\d{4})?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d{3,5}([- ]?\\d{4})?$', 'gm')
const str = `27364
2839
37567-2839
28448 3950
3847933
28448 3953
3
3858049494
38494 4
49500-
49500-35
49500-35-34
-32893-3429
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}