import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d{3,5}([- ]?\\d{4})?$";
final String string = "27364\n"
+ "2839\n"
+ "37567-2839\n"
+ "28448 3950\n"
+ "3847933\n"
+ "28448 3953\n\n\n"
+ "3\n"
+ "3858049494\n"
+ "38494 4\n"
+ "49500-\n"
+ "49500-35\n"
+ "49500-35-34\n"
+ "-32893-3429\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}