# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\d{3,5}([- ]?\d{4})?$"
test_str = ("27364\n"
"2839\n"
"37567-2839\n"
"28448 3950\n"
"3847933\n"
"28448 3953\n\n\n"
"3\n"
"3858049494\n"
"38494 4\n"
"49500-\n"
"49500-35\n"
"49500-35-34\n"
"-32893-3429\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.