package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{3,5}([- ]?\d{4})?$`)
var str = `27364
2839
37567-2839
28448 3950
3847933
28448 3953
3
3858049494
38494 4
49500-
49500-35
49500-35-34
-32893-3429
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}