using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d{3,5}([- ]?\d{4})?$";
string input = @"27364
2839
37567-2839
28448 3950
3847933
28448 3953
3
3858049494
38494 4
49500-
49500-35
49500-35-34
-32893-3429
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}