re = /^\d{3,5}([- ]?\d{4})?$/m
str = '27364
2839
37567-2839
28448 3950
3847933
28448 3953
3
3858049494
38494 4
49500-
49500-35
49500-35-34
-32893-3429
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end